USN-1886-1: Puppet vulnerability

18 June 2013

puppet vulnerability

Packages

  • puppet - Centralized configuration management

Details

It was discovered that Puppet incorrectly handled YAML payloads. An
attacker on an untrusted client could use this issue to execute arbitrary
code on the master.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 13.04
Ubuntu 12.10
Ubuntu 12.04

In general, a standard system update will make all the necessary changes.

References