USN-1408-1: Linux kernel (FSL-IMX51) vulnerability

27 March 2012

The system could be made to crash under certain conditions.

Releases

Packages

  • linux-fsl-imx51 - Linux kernel for IMX51

Details

Louis Rilling discovered a flaw in Linux kernel's clone command when
CLONE_IO is specified. An unprivileged local user could exploit this to
cause a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 10.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed. If
you use linux-restricted-modules, you have to update that package as
well to get modules which work with the new kernel version. Unless you
manually uninstalled the standard kernel metapackages (e.g. linux-generic,
linux-server, linux-powerpc), a standard system upgrade will automatically
perform this as well.

References

Related notices

  • USN-1410-1: linux-ec2, linux-image-2.6.32-344-ec2
  • USN-1411-1: linux-image-2.6.32-40-lpia, linux-image-2.6.32-40-386, linux-image-2.6.32-40-versatile, linux-image-2.6.32-40-sparc64, linux-image-2.6.32-40-powerpc64-smp, linux-image-2.6.32-40-server, linux-image-2.6.32-40-preempt, linux, linux-image-2.6.32-40-ia64, linux-image-2.6.32-40-sparc64-smp, linux-image-2.6.32-40-powerpc, linux-image-2.6.32-40-virtual, linux-image-2.6.32-40-generic-pae, linux-image-2.6.32-40-powerpc-smp, linux-image-2.6.32-40-generic