Your submission was sent successfully! Close

USN-1287-1: Linux (OMAP4) vulnerability

5 December 2011

The system could be made to crash under certain conditions.

Releases

Packages

Details

Nick Bowler discovered the kernel GHASH message digest algorithm
incorrectly handled error conditions. A local attacker could exploit this
to cause a kernel oops.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 11.10

After a standard system update you need to reboot your computer to make
all the necessary changes.

References

Related notices

  • USN-1292-1: linux-lts-backport-maverick, linux-image-2.6.35-31-virtual, linux-image-2.6.35-31-generic, linux-image-2.6.35-31-generic-pae, linux-image-2.6.35-31-server
  • USN-1302-1: linux-ti-omap4, linux-image-2.6.35-903-omap4
  • USN-1299-1: linux-image-2.6.32-341-ec2, linux-ec2
  • USN-1322-1: linux-image-3.0.0-14-powerpc, linux-image-3.0.0-14-generic, linux-image-3.0.0-14-powerpc-smp, linux-image-3.0.0-14-virtual, linux-image-3.0.0-14-omap, linux-image-3.0.0-14-generic-pae, linux-image-3.0.0-14-server, linux, linux-image-3.0.0-14-powerpc64-smp
  • USN-1301-1: linux-image-2.6.38-13-generic, linux-image-2.6.38-13-generic-pae, linux-image-2.6.38-13-virtual, linux-lts-backport-natty, linux-image-2.6.38-13-server
  • USN-1312-1: linux-image-2.6.38-13-powerpc, linux-image-2.6.38-13-omap, linux, linux-image-2.6.38-13-powerpc64-smp, linux-image-2.6.38-13-powerpc-smp, linux-image-2.6.38-13-versatile, linux-image-2.6.38-13-generic, linux-image-2.6.38-13-generic-pae, linux-image-2.6.38-13-virtual, linux-image-2.6.38-13-server
  • USN-1303-1: linux-mvl-dove, linux-image-2.6.32-421-dove
  • USN-1293-1: linux-image-2.6.35-31-powerpc, linux-image-2.6.35-31-powerpc-smp, linux-image-2.6.35-31-omap, linux-image-2.6.35-31-virtual, linux-image-2.6.35-31-powerpc64-smp, linux, linux-image-2.6.35-31-generic, linux-image-2.6.35-31-versatile, linux-image-2.6.35-31-generic-pae, linux-image-2.6.35-31-server
  • USN-1311-1: linux-image-2.6.32-37-virtual, linux-image-2.6.32-37-generic, linux-image-2.6.32-37-server, linux-image-2.6.32-37-powerpc64-smp, linux-image-2.6.32-37-powerpc, linux-image-2.6.32-37-386, linux-image-2.6.32-37-lpia, linux-image-2.6.32-37-preempt, linux-image-2.6.32-37-generic-pae, linux, linux-image-2.6.32-37-versatile, linux-image-2.6.32-37-sparc64, linux-image-2.6.32-37-ia64, linux-image-2.6.32-37-sparc64-smp, linux-image-2.6.32-37-powerpc-smp
  • USN-1304-1: linux-image-2.6.38-1209-omap4, linux-ti-omap4
  • USN-1313-1: linux-image-3.0.0-14-generic, linux-image-3.0.0-14-virtual, linux-image-3.0.0-14-generic-pae, linux-image-3.0.0-14-server, linux-lts-backport-oneiric