USN-1118-1: OpenSLP vulnerability

20 April 2011

An attacker could send crafted input to OpenSLP and cause it to hang.

Releases

Packages

  • openslp - OpenSLP is an implementation of the Service Location Protocol
  • openslp-dfsg - OpenSLP is an implementation of the Service Location Protocol

Details

It was discovered that OpenSLP incorrectly handled certain corrupted
messages. A remote attacker could send a specially crafted packet to
the OpenSLP server and cause it to hang, leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.10
Ubuntu 8.04
Ubuntu 6.06
Ubuntu 10.10
Ubuntu 10.04

In general, a standard system update will make all the necessary changes.

References