USN-1096-1: Subversion vulnerability

29 March 2011

An attacker could send crafted input to the Subversion mod_dav_svn module for Apache and cause it to crash.

Releases

Packages

  • subversion - Advanced version control system

Details

Philip Martin discovered that the Subversion mod_dav_svn module for Apache
did not properly handle certain requests containing a lock token. A remote
attacker could use this flaw to cause the service to crash, leading to a
denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 9.10
Ubuntu 8.04
Ubuntu 6.06
Ubuntu 10.10
Ubuntu 10.04

After a standard system update you need to restart any applications that
use Subversion, such as Apache when using mod_dav_svn, to make all the
necessary changes.

References