Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2024-5687

Published: 11 June 2024

If a specific sequence of actions is performed when opening a new tab, the triggering principal associated with the new tab may have been incorrect. The triggering principal is used to calculate many values, including the `Referer` and `Sec-*` headers, meaning there is the potential for incorrect security checks within the browser in addition to incorrect or misleading information sent to remote websites. *This bug only affects Firefox for Android. Other versions of Firefox are unaffected.* This vulnerability affects Firefox < 127.

Notes

AuthorNote
tyhicks
mozjs contains a copy of the SpiderMonkey JavaScript engine
mdeslaur
starting with Ubuntu 22.04, the firefox package is just a script
that installs the Firefox snap
starting with Ubuntu 24.04, the thunderbird package is just a
script that installs the Thunderbird snap

Priority

Medium

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
focal Not vulnerable
(android specific)
jammy Not vulnerable
(code not present)
mantic Not vulnerable
(code not present)
noble Not vulnerable
(code not present)
upstream Needs triage

thunderbird
Launchpad, Ubuntu, Debian
focal Not vulnerable
(android specific)
jammy Not vulnerable
(android specific)
mantic Not vulnerable
(android specific)
noble Not vulnerable
(code not present)
upstream Needs triage