Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2024-4577

Published: 9 June 2024

In PHP versions 8.1.* before 8.1.29, 8.2.* before 8.2.20, 8.3.* before 8.3.8, when using Apache and PHP-CGI on Windows, if the system is set up to use certain code pages, Windows may use "Best-Fit" behavior to replace characters in command line given to Win32 API functions. PHP CGI module may misinterpret those characters as PHP options, which may allow a malicious user to pass options to PHP binary being run, and thus reveal the source code of scripts, run arbitrary PHP code on the server, etc.

Notes

AuthorNote
mdeslaur
This appears to be a Windows specific issue, marking as
not-affected

Priority

Medium

Cvss 3 Severity Score

9.8

Score breakdown

Status

Package Release Status
php5
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

trusty Not vulnerable
(windows-specific)
upstream Needs triage

php7.0
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Needs triage

xenial Not vulnerable
(windows-specific)
php7.2
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(windows-specific)
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Needs triage

php7.4
Launchpad, Ubuntu, Debian
focal Not vulnerable
(windows-specific)
jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Needs triage

php8.1
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Not vulnerable
(windows-specific)
mantic Does not exist

noble Does not exist

upstream Needs triage

php8.2
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Not vulnerable
(windows-specific)
noble Does not exist

upstream Needs triage

php8.3
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Not vulnerable
(windows-specific)
upstream Needs triage

Patches:
upstream: https://github.com/php/php-src/commit/b6d1d3980a664882f03021e9bb918089ed3dc428

Severity score breakdown

Parameter Value
Base score 9.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H