Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2024-4317

Published: 14 May 2024

Missing authorization in PostgreSQL built-in views pg_stats_ext and pg_stats_ext_exprs allows an unprivileged database user to read most common values and other statistics from CREATE STATISTICS commands of other users. The most common values may reveal column values the eavesdropper could not otherwise read or results of functions they cannot execute. Installing an unaffected version only fixes fresh PostgreSQL installations, namely those that are created with the initdb utility after installing that version. Current PostgreSQL installations will remain vulnerable until they follow the instructions in the release notes. Within major versions 14-16, minor versions before PostgreSQL 16.3, 15.7, and 14.12 are affected. Versions before PostgreSQL 14 are unaffected.

Notes

AuthorNote
leosilva
PostgreSQL 9.3 is end of life upstream, and no updates are
are available. Marking as deferred in -esm-main releases.

Priority

Medium

Status

Package Release Status
postgresql-10
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Needs triage

postgresql-12
Launchpad, Ubuntu, Debian
focal Needs triage

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Needs triage

postgresql-14
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Needs triage

mantic Does not exist

noble Does not exist

upstream Needs triage

postgresql-15
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Needs triage

noble Does not exist

upstream Needs triage

postgresql-16
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Needs triage

upstream Needs triage

postgresql-9.1
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Needs triage

postgresql-9.3
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

trusty Deferred
(2019-08-23)
upstream Needs triage

postgresql-9.5
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Does not exist

noble Does not exist

upstream Needs triage

xenial Needs triage