Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2024-0071

Published: 27 March 2024

NVIDIA GPU Display Driver for Windows contains a vulnerability in the user mode layer, where an unprivileged regular user can cause an out-of-bounds write. A successful exploit of this vulnerability may lead to code execution, denial of service, escalation of privileges, information disclosure, and data tampering.

Notes

AuthorNote
mdeslaur
some binary drivers are no longer support by NVidia, so they
are marked as ignored here
rodrigo-zaiden
affected Windows driver only.

Priority

Medium

Status

Package Release Status
nvidia-graphics-drivers-304
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Does not exist

upstream Not vulnerable
(Windows only)
xenial Ignored

nvidia-graphics-drivers-304-updates
Launchpad, Ubuntu, Debian
focal Does not exist

jammy Does not exist

mantic Does not exist

upstream Not vulnerable
(Windows only)
xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-340
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Ignored

jammy Not vulnerable
(superseded)
mantic Not vulnerable
(superseded)
upstream Not vulnerable
(Windows only)
xenial Ignored

nvidia-graphics-drivers-340-updates
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Does not exist

jammy Does not exist

mantic Does not exist

upstream Not vulnerable
(Windows only)
xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-352
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Does not exist

jammy Does not exist

mantic Does not exist

upstream Not vulnerable
(Windows only)
xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-352-updates
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Does not exist

jammy Does not exist

mantic Does not exist

upstream Not vulnerable
(Windows only)
xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-361
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Does not exist

jammy Does not exist

mantic Does not exist

upstream Not vulnerable
(Windows only)
xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-367
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Does not exist

jammy Does not exist

mantic Does not exist

upstream Not vulnerable
(Windows only)
xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-375
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Does not exist

jammy Does not exist

mantic Does not exist

upstream Not vulnerable
(Windows only)
xenial Not vulnerable
(superseded)
nvidia-graphics-drivers-384
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Does not exist

jammy Does not exist

mantic Does not exist

upstream Not vulnerable
(Windows only)
xenial Not vulnerable
(Windows only)
nvidia-graphics-drivers-390
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Ignored

jammy Ignored

mantic Does not exist

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-418-server
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Ignored

jammy Ignored

mantic Does not exist

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-430
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Ignored

jammy Ignored

mantic Ignored

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-435
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Ignored

jammy Ignored

mantic Ignored

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-440
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Ignored

jammy Ignored

mantic Ignored

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-440-server
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Ignored

jammy Ignored

mantic Does not exist

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-450
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Ignored

jammy Ignored

mantic Ignored

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-450-server
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Does not exist

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-455
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Ignored

jammy Ignored

mantic Ignored

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-460
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Ignored

jammy Ignored

mantic Ignored

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-460-server
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Ignored

jammy Does not exist

mantic Does not exist

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-470
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Not vulnerable
(Windows only)
upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-470-server
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Not vulnerable
(Windows only)
upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-495
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(superseded)
jammy Does not exist

mantic Does not exist

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-510
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Ignored

jammy Ignored

mantic Ignored

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-510-server
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(superseded)
jammy Not vulnerable
(superseded)
mantic Does not exist

upstream Not vulnerable
(superseded)
nvidia-graphics-drivers-515
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Not vulnerable
(Windows only)
upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-515-server
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Not vulnerable
(Windows only)
upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-520
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Ignored

jammy Ignored

mantic Does not exist

upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-525
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Not vulnerable
(Windows only)
upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-525-server
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Not vulnerable
(Windows only)
upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-530
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(Windows only)
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Not vulnerable
(Windows only)
upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-535
Launchpad, Ubuntu, Debian
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Not vulnerable
(Windows only)
upstream Not vulnerable
(Windows only)
nvidia-graphics-drivers-535-server
Launchpad, Ubuntu, Debian
focal Not vulnerable
(Windows only)
jammy Not vulnerable
(Windows only)
mantic Not vulnerable
(Windows only)
upstream Not vulnerable
(Windows only)