Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2023-49083

Published: 4 December 2023

cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. Calling `load_pem_pkcs7_certificates` or `load_der_pkcs7_certificates` could lead to a NULL-pointer dereference and segfault. Exploitation of this vulnerability poses a serious risk of Denial of Service (DoS) for any application attempting to deserialize a PKCS7 blob/certificate. The consequences extend to potential disruptions in system availability and stability. This vulnerability has been patched in version 41.0.6.

Notes

AuthorNote
mdeslaur
only affects 3.1 and higher

Priority

Medium

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
python-cryptography
Launchpad, Ubuntu, Debian
trusty Ignored
(end of standard support)
xenial Not vulnerable
(code not present)
bionic Not vulnerable
(code not present)
upstream Needs triage

focal Not vulnerable
(code not present)
jammy
Released (3.4.8-1ubuntu2.1)
lunar
Released (38.0.4-2ubuntu0.1)
mantic
Released (38.0.4-4ubuntu0.23.10.1)
Patches:
upstream: https://github.com/pyca/cryptography/pull/9926
upstream: https://github.com/pyca/cryptography/commit/1e7b4d074e14c4e694d3ce69ad6754a6039fd6ff (main)
upstream: https://github.com/pyca/cryptography/commit/f09c261ca10a31fe41b1262306db7f8f1da0e48a (41.0.6)

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H