Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-44570

Published: 9 February 2023

A denial of service vulnerability in the Range header parsing component of Rack >= 1.5.0. A Carefully crafted input can cause the Range header parsing component in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that deal with Range requests (such as streaming applications, or applications that serve files) may be impacted.

Priority

Medium

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
ruby-rack
Launchpad, Ubuntu, Debian
kinetic Ignored
(end of life, was needed)
bionic
Released (1.6.4-4ubuntu0.2+esm4)
Available with Ubuntu Pro
focal
Released (2.0.7-2ubuntu0.1+esm3)
Available with Ubuntu Pro
jammy
Released (2.1.4-5ubuntu1+esm3)
Available with Ubuntu Pro
trusty
Released (1.5.2-3+deb8u3ubuntu1~esm6)
Available with Ubuntu Pro or Ubuntu Pro (Infra-only)
upstream
Released (2.0.9.2, 2.1.4.2, 2.2.6.2, 3.0.4.1)
xenial
Released (1.6.4-3ubuntu0.2+esm4)
Available with Ubuntu Pro
mantic Not vulnerable
(2.2.4-3)
lunar Not vulnerable
(2.2.4-3)
Patches:
upstream: https://github.com/rack/rack/commit/52721ae0b730e3920ad5375dfd5a3ea9b4f9e359 (v2.0.9.2)
upstream: https://github.com/rack/rack/commit/f66ef5c8255dcea82c1b2665fc9ab948b76bb437 (v2.1.4.2)
upstream: https://github.com/rack/rack/commit/f6d4f528f2df1318a6612845db0b59adc7fe8fc1 (v2.2.6.2)

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H