Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-37026

Published: 21 September 2022

In Erlang/OTP before 23.3.4.15, 24.x before 24.3.4.2, and 25.x before 25.0.2, there is a Client Authentication Bypass in certain client-certification situations for SSL, TLS, and DTLS.

From the Ubuntu Security Team

It was discovered that Erlang did not properly implement TLS client certificate validation during the TLS handshake. A remote attacker could use this issue to bypass client authentication.

Notes

AuthorNote
mdeslaur
only an issue when client certificates are used

Priority

Medium

Cvss 3 Severity Score

9.8

Score breakdown

Status

Package Release Status
erlang
Launchpad, Ubuntu, Debian
bionic Needs triage

focal
Released (1:22.2.7+dfsg-1ubuntu0.2)
jammy
Released (1:24.2.1+dfsg-1ubuntu0.1)
kinetic
Released (1:24.3.4.1+dfsg-1ubuntu0.1)
lunar
Released (1:24.3.4.5+dfsg-1)
mantic
Released (1:24.3.4.5+dfsg-1)
trusty Needs triage

upstream Needs triage

xenial Needs triage

Patches:
upstream: https://github.com/erlang/otp/commit/cd5024867e7b7d3a6e94194af9e01e1fb77e36c9
upstream: https://github.com/erlang/otp/commit/6a1baa36e4e6c1b682e8b48e0c141602e0b8e6e5
upstream: https://github.com/erlang/otp/commit/254f2728902bc7e80a67726ebbc1a0b3ab7742eb
upstream: https://github.com/erlang/otp/commit/33e7570e075e0b84efef91b2f307fcf938517b1c
opensuse: https://build.opensuse.org/package/view_file/SUSE:SLE-15-SP3:Update/erlang/CVE-2022-37026-client-auth-bypass.patch?expand=1

Severity score breakdown

Parameter Value
Base score 9.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H