Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2022-36315

Published: 27 July 2022

When loading a script with Subresource Integrity, attackers with an injection capability could trigger the reuse of previously cached entries with incorrect, different integrity metadata. This vulnerability affects Firefox < 103.

Notes

AuthorNote
mdeslaur
starting with Ubuntu 22.04, the firefox package is just a script
that installs the Firefox snap

Priority

Low

Cvss 3 Severity Score

4.3

Score breakdown

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
trusty Does not exist

kinetic Not vulnerable
(code not present)
lunar Not vulnerable
(code not present)
jammy Not vulnerable
(code not present)
bionic
Released (103.0+build1-0ubuntu0.18.04.1)
focal
Released (103.0+build1-0ubuntu0.20.04.1)
upstream
Released (103)
xenial Ignored
(end of standard support)
thunderbird
Launchpad, Ubuntu, Debian
jammy
Released (1:102.2.2+build1-0ubuntu0.22.04.1)
upstream
Released (102.1)
kinetic Ignored
(end of life, was needed)
lunar Not vulnerable
(1:102.3.3+build1-0ubuntu1)
trusty Does not exist

focal
Released (1:102.2.2+build1-0ubuntu0.20.04.1)
bionic Ignored
(end of standard support, was needed)
xenial Ignored
(end of standard support)

Severity score breakdown

Parameter Value
Base score 4.3
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality None
Integrity impact Low
Availability impact None
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N