Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2022-3328

Published: 30 November 2022

Race condition in snap-confine's must_mkdir_and_open_with_perms()

From the Ubuntu Security Team

The Qualys Research Team discovered that a race condition existed in the snapd snap-confine binary when preparing the private /tmp mount for a snap. A local attacker could possibly use this issue to escalate privileges and execute arbitrary code.

Notes

AuthorNote
alexmurray
vuln introduced as part of the fix for CVE-2021-44731 - as such affects upstream versions 2.54.3 to 2.57.5

Priority

High

Cvss 3 Severity Score

7.8

Score breakdown

Status

Package Release Status
snapd
Launchpad, Ubuntu, Debian
bionic
Released (2.57.5+18.04ubuntu0.1)
focal
Released (2.57.5+20.04ubuntu0.1)
jammy
Released (2.57.5+22.04ubuntu0.1)
kinetic
Released (2.57.5+22.10ubuntu0.1)
trusty Ignored
(out of standard support)
upstream Needs triage

xenial
Released (2.54.3+16.04.0ubuntu0.1~esm5)

Severity score breakdown

Parameter Value
Base score 7.8
Attack vector Local
Attack complexity High
Privileges required Low
User interaction None
Scope Changed
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H