Your submission was sent successfully! Close

CVE-2022-29187

Published: 12 July 2022

Git is a distributed revision control system. Git prior to versions 2.37.1, 2.36.2, 2.35.4, 2.34.4, 2.33.4, 2.32.3, 2.31.4, and 2.30.5, is vulnerable to privilege escalation in all platforms. An unsuspecting user could still be affected by the issue reported in CVE-2022-24765, for example when navigating as root into a shared tmp directory that is owned by them, but where an attacker could create a git repository. Versions 2.37.1, 2.36.2, 2.35.4, 2.34.4, 2.33.4, 2.32.3, 2.31.4, and 2.30.5 contain a patch for this issue. The simplest way to avoid being affected by the exploit described in the example is to avoid running git as root (or an Administrator in Windows), and if needed to reduce its use to a minimum. While a generic workaround is not possible, a system could be hardened from the exploit described in the example by removing any such repository if it exists already and creating one as root to block any future attacks.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
git
Launchpad, Ubuntu, Debian
bionic
Released (1:2.17.1-1ubuntu0.12)
focal
Released (1:2.25.1-1ubuntu3.5)
impish
Released (1:2.32.0-1ubuntu1.3)
jammy
Released (1:2.34.1-1ubuntu1.4)
trusty Does not exist

upstream Needs triage

xenial Needs triage