Your submission was sent successfully! Close

CVE-2021-45944

Published: 01 January 2022

Ghostscript GhostPDL 9.50 through 9.53.3 has a use-after-free in sampled_data_sample (called from sampled_data_continue and interp).

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
ghostscript
Launchpad, Ubuntu, Debian
Upstream
Released (9.54.0~dfsg-5)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(9.54.0~dfsg1-0ubuntu2)
Ubuntu 21.04 (Hirsute Hippo)
Released (9.53.3~dfsg-7ubuntu0.2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (9.50~dfsg-5ubuntu4.5)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (9.26~dfsg+0-0ubuntu0.18.04.15)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (9.26~dfsg+0-0ubuntu0.16.04.14+esm1)
Ubuntu 14.04 ESM (Trusty Tahr) Ignored
(out of standard support)
Patches:
Upstream: https://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=7861fcad13c497728189feafb41cd57b5b50ea25