Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2021-3559

Published: 24 May 2021

A flaw was found in libvirt in the virConnectListAllNodeDevices API in versions before 7.0.0. It only affects hosts with a PCI device and driver that supports mediated devices (e.g., GRID driver). This flaw could be used by an unprivileged client with a read-only connection to crash the libvirt daemon by executing the 'nodedev-list' virsh command. The highest threat from this vulnerability is to system availability.

Notes

AuthorNote
mdeslaur
introduced in 6.10.0-rc1, fixed in 7.0.0-rc1

Priority

Medium

Cvss 3 Severity Score

6.5

Score breakdown

Status

Package Release Status
libvirt
Launchpad, Ubuntu, Debian
jammy Not vulnerable
(7.0.0-2ubuntu2)
impish Not vulnerable
(7.0.0-2ubuntu2)
bionic Not vulnerable
(4.0.0-1ubuntu8.19)
focal Not vulnerable
(6.0.0-0ubuntu8.9)
groovy Not vulnerable
(6.6.0-1ubuntu3.5)
hirsute Not vulnerable
(7.0.0-2ubuntu2)
trusty Not vulnerable

upstream Not vulnerable
(debian: Vulnerable code never in a released version)
xenial Not vulnerable

Severity score breakdown

Parameter Value
Base score 6.5
Attack vector Network
Attack complexity Low
Privileges required Low
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H