Your submission was sent successfully! Close

CVE-2021-3450

Published: 25 March 2021

The X509_V_FLAG_X509_STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that have explicitly encoded elliptic curve parameters was added as an additional strict check. An error in the implementation of this check meant that the result of a previous check to confirm that certificates in the chain are valid CA certificates was overwritten. This effectively bypasses the check that non-CA certificates must not be able to issue other certificates. If a "purpose" has been configured then there is a subsequent opportunity for checks that the certificate is a valid CA. All of the named "purpose" values implemented in libcrypto perform this check. Therefore, where a purpose is set the certificate chain will still be rejected even when the strict flag has been used. A purpose is set by default in libssl client and server certificate verification routines, but it can be overridden or removed by an application. In order to be affected, an application must explicitly set the X509_V_FLAG_X509_STRICT verification flag and either not set a purpose for the certificate verification or, in the case of TLS client or server applications, override the default purpose. OpenSSL versions 1.1.1h and newer are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j).

Priority

High

CVSS 3 base score: 7.4

Status

Package Release Status
edk2
Launchpad, Ubuntu, Debian
bionic Not vulnerable

focal Not vulnerable

groovy Not vulnerable

precise Does not exist

trusty Does not exist

upstream Not vulnerable

xenial Not vulnerable

nodejs
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(uses system openssl1.0)
focal Not vulnerable
(uses system openssl1.1)
groovy Not vulnerable
(uses system openssl1.1)
precise Does not exist

trusty Not vulnerable
(uses system openssl)
upstream Needs triage

xenial Not vulnerable
(uses system openssl)
openssl
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(1.1.1-1ubuntu2.1~18.04.8)
focal Not vulnerable
(1.1.1f-1ubuntu2.2)
groovy Not vulnerable
(1.1.1f-1ubuntu4.2)
precise Not vulnerable

trusty Not vulnerable

upstream Needs triage

xenial Not vulnerable
(1.0.2g-1ubuntu4.19)
openssl1.0
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(1.0.2n-1ubuntu5.6)
focal Does not exist

groovy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

Notes

AuthorNote
mdeslaur
only affects 1.1.1h and later
edk2 in Ubuntu contains an embedded OpenSSL earlier than 1.1.1h

References

Bugs