CVE-2021-3345

Published: 29 January 2021

_gcry_md_block_write in cipher/hash-common.c in Libgcrypt version 1.9.0 has a heap-based buffer overflow when the digest final function sets a large count value. It is recommended to upgrade to 1.9.1 or later.

Priority

High

CVSS 3 base score: 7.8

Status

Package Release Status
libgcrypt11
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1.5.3-2ubuntu4.6+esm1)
libgcrypt20
Launchpad, Ubuntu, Debian
Upstream
Released (1.9.1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.8.5-5ubuntu2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.8.5-5ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.8.1-4ubuntu1.2)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(1.6.5-2ubuntu0.6)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist