Your submission was sent successfully! Close

CVE-2021-23017

Published: 25 May 2021

A security issue in nginx resolver was identified, which might allow an attacker who is able to forge UDP packets from the DNS server to cause 1-byte memory overwrite, resulting in worker process crash or potential other impact.

Priority

Medium

CVSS 3 base score: 9.4

Status

Package Release Status
nginx
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri)
Released (1.18.0-6ubuntu9)
Ubuntu 21.04 (Hirsute Hippo)
Released (1.18.0-6ubuntu8.2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (1.18.0-0ubuntu1.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.14.0-0ubuntu1.9)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.10.3-0ubuntu0.16.04.5+esm1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.4.6-1ubuntu3.9+esm2)
Patches:
Upstream: http://nginx.org/download/patch.2021.resolver.txt