Your submission was sent successfully! Close

CVE-2021-22946

Published: 15 September 2021

A user can tell curl >= 7.20.0 and <= 7.78.0 to require a successful upgrade to TLS when speaking to an IMAP, POP3 or FTP server (`--ssl-reqd` on the command line or`CURLOPT_USE_SSL` set to `CURLUSESSL_CONTROL` or `CURLUSESSL_ALL` withlibcurl). This requirement could be bypassed if the server would return a properly crafted but perfectly legitimate response.This flaw would then make curl silently continue its operations **withoutTLS** contrary to the instructions and expectations, exposing possibly sensitive data in clear text over the network.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
curl
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri)
Released (7.74.0-1.3ubuntu2)
Ubuntu 21.04 (Hirsute Hippo)
Released (7.74.0-1ubuntu2.3)
Ubuntu 20.04 LTS (Focal Fossa)
Released (7.68.0-1ubuntu2.7)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (7.58.0-2ubuntu3.15)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (7.47.0-1ubuntu2.19+esm1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (7.35.0-1ubuntu2.20+esm8)

Notes

AuthorNote
mdeslaur
introduced by:
https://github.com/curl/curl/commit/ec3bb8f727405 and
https://github.com/curl/curl/commit/c5ba0c2f544653

References