Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2021-21775

Published: 7 July 2021

A use-after-free vulnerability exists in the way certain events are processed for ImageLoader objects of Webkit WebKitGTK 2.30.4. A specially crafted web page can lead to a potential information leak and further memory corruption. In order to trigger the vulnerability, a victim must be tricked into visiting a malicious webpage.

Notes

AuthorNote
jdstrand
webkit receives limited support. For details, see
https://wiki.ubuntu.com/SecurityTeam/FAQ#webkit
webkit in Ubuntu uses the JavaScriptCore (JSC) engine, not V8

Priority

Medium

Cvss 3 Severity Score

8.0

Score breakdown

Status

Package Release Status
qtwebkit-source
Launchpad, Ubuntu, Debian
impish Does not exist

lunar Does not exist

bionic Needs triage

focal Does not exist

groovy Does not exist

hirsute Does not exist

trusty Does not exist

upstream Needs triage

xenial Needs triage

jammy Does not exist

kinetic Does not exist

mantic Does not exist

webkit2gtk
Launchpad, Ubuntu, Debian
focal
Released (2.32.3-0ubuntu0.20.04.1)
groovy Ignored
(end of life)
hirsute
Released (2.32.3-0ubuntu0.21.04.1)
impish
Released (2.32.3-1ubuntu1)
lunar
Released (2.32.3-1ubuntu1)
upstream
Released (2.32.3)
trusty Does not exist

xenial Deferred

bionic
Released (2.32.3-0ubuntu0.18.04.1)
jammy
Released (2.32.3-1ubuntu1)
kinetic
Released (2.32.3-1ubuntu1)
mantic
Released (2.32.3-1ubuntu1)
webkitgtk
Launchpad, Ubuntu, Debian
groovy Does not exist

hirsute Does not exist

impish Does not exist

lunar Does not exist

trusty Does not exist

upstream Needs triage

xenial Needs triage

bionic Needs triage

focal Does not exist

jammy Does not exist

kinetic Does not exist

mantic Does not exist

wpewebkit
Launchpad, Ubuntu, Debian
bionic Does not exist

focal Needs triage

groovy Ignored
(end of life)
hirsute Ignored
(end of life)
lunar Does not exist

trusty Does not exist

upstream Needs triage

xenial Does not exist

jammy Needs triage

impish Ignored
(end of life)
kinetic Does not exist

mantic Does not exist

qtwebkit-opensource-src
Launchpad, Ubuntu, Debian
bionic Needs triage

focal Needs triage

trusty Does not exist

upstream Needs triage

xenial Needs triage

groovy Ignored
(end of life)
hirsute Ignored
(end of life)
jammy Needs triage

impish Ignored
(end of life)
kinetic Ignored
(end of life, was needs-triage)
mantic Needs triage

lunar Ignored
(end of life, was needs-triage)

Severity score breakdown

Parameter Value
Base score 8.0
Attack vector Network
Attack complexity Low
Privileges required Low
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H