Your submission was sent successfully! Close

CVE-2021-20305

Published: 5 April 2021

A flaw was found in Nettle in versions before 3.7.2, where several Nettle signature verification functions (GOST DSA, EDDSA & ECDSA) result in the Elliptic Curve Cryptography point (ECC) multiply function being called with out-of-range scalers, possibly resulting in incorrect results. This flaw allows an attacker to force an invalid signature, causing an assertion failure or possible validation. The highest threat to this vulnerability is to confidentiality, integrity, as well as system availability.

Priority

Medium

CVSS 3 base score: 8.1

Status

Package Release Status
nettle
Launchpad, Ubuntu, Debian
bionic
Released (3.4-1ubuntu0.1)
focal
Released (3.5.1+really3.5.1-2ubuntu0.1)
groovy
Released (3.6-2ubuntu0.1)
hirsute
Released (3.7-2.1ubuntu1)
impish
Released (3.7-2.1ubuntu1)
jammy
Released (3.7-2.1ubuntu1)
precise Does not exist

trusty Needs triage

upstream
Released (3.7.2-1)
xenial
Released (3.2-1ubuntu0.16.04.2)