Your submission was sent successfully! Close

CVE-2021-20237

Published: 28 May 2021

An uncontrolled resource consumption (memory leak) flaw was found in ZeroMQ's src/xpub.cpp in versions before 4.3.3. This flaw allows a remote unauthenticated attacker to send crafted PUB messages that consume excessive memory if the CURVE/ZAP authentication is disabled on the server, causing a denial of service. The highest threat from this vulnerability is to system availability.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
zeromq3
Launchpad, Ubuntu, Debian
Upstream
Released (4.3.3-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(4.3.4-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.3.4-1)
Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Needs triage

Patches:
Upstream: https://github.com/zeromq/libzmq/pull/3935