Your submission was sent successfully! Close

CVE-2021-20235

Published: 01 April 2021

There's a flaw in the zeromq server in versions before 4.3.3 in src/decoder_allocators.hpp. The decoder static allocator could have its sized changed, but the buffer would remain the same as it is a static buffer. A remote, unauthenticated attacker who sends a crafted request to the zeromq server could trigger a buffer overflow WRITE of arbitrary data if CURVE/ZAP authentication is not enabled. The greatest impact of this flaw is to application availability, data integrity, and confidentiality.

Priority

Medium

CVSS 3 base score: 8.1

Status

Package Release Status
zeromq3
Launchpad, Ubuntu, Debian
Upstream
Released (4.3.3-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(4.3.4-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.3.4-1)
Ubuntu 20.04 LTS (Focal Fossa) Needed

Ubuntu 18.04 LTS (Bionic Beaver) Needed

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Needs triage

Patches:
Upstream: https://github.com/zeromq/libzmq/pull/3902