Your submission was sent successfully! Close

CVE-2021-20208

Published: 19 April 2021

A flaw was found in cifs-utils in versions before 6.13. A user when mounting a krb5 CIFS file system from within a container can use Kerberos credentials of the host. The highest threat from this vulnerability is to data confidentiality and integrity.

Priority

Low

CVSS 3 base score: 6.1

Status

Package Release Status
cifs-utils
Launchpad, Ubuntu, Debian
bionic
Released (2:6.8-1ubuntu1.2)
focal
Released (2:6.9-1ubuntu0.2)
groovy Ignored
(reached end-of-life)
hirsute Ignored
(reached end-of-life)
impish Not vulnerable
(2:6.11-3.1)
jammy Not vulnerable
(2:6.14-1build1)
precise Ignored
(end of ESM support, was needs-triage)
trusty Needs triage

upstream
Released (6.14,2:6.11-3.1)
xenial Needs triage

Patches:
upstream: https://git.samba.org/cifs-utils.git/?p=cifs-utils.git;a=commit;h=e461afd8cfa6d0781ae0c5c10e89b6ef1ca6da32
upstream: https://git.samba.org/cifs-utils.git/?p=cifs-utils.git;a=commit;h=7f9711dd902a239c499682015d708f73ec884af2 (regression)

Notes

AuthorNote
mdeslaur
per Red Hat bug, 6.13 was missing two important fixes, and
6.14 is required.
per Debian, causes a regression, see:
https://bugs.debian.org/989080
https://www.spinics.net/lists/linux-cifs/msg21976.html

References

Bugs