CVE-2020-7729

Published: 03 September 2020

The package grunt before 1.3.0 are vulnerable to Arbitrary Code Execution due to the default usage of the function load() instead of its secure replacement safeLoad() of the package js-yaml inside grunt.file.readYAML.

Priority

Medium

CVSS 3 base score: 7.1

Status

Package Release Status
grunt
Launchpad, Ubuntu, Debian
Upstream
Released (1.3.0-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.3.0-1)
Ubuntu 20.10 (Groovy Gorilla) Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.0.1-8ubuntu0.1)
Ubuntu 16.04 LTS (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Ubuntu 12.04 ESM (Precise Pangolin) Does not exist