CVE-2020-36332

Published: 31 December 2020

A flaw was found in libwebp in versions before 1.0.1. When reading a file libwebp allocates an excessive amount of memory. The highest threat from this vulnerability is to the service availability.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
libwebp
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri)
Released (0.6.1-2ubuntu1)
Ubuntu 21.04 (Hirsute Hippo)
Released (0.6.1-2ubuntu0.21.04.1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (0.6.1-2ubuntu0.20.04.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.6.1-2ubuntu0.18.04.1)
Ubuntu 16.04 ESM (Xenial Xerus) Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable

Patches:
Upstream: https://chromium.googlesource.com/webm/libwebp/+/dce5d7643177633ebe3513af492ea8c08c299cf3 (pre)
Upstream: https://chromium.googlesource.com/webm/libwebp/+/39cb9aad85ca7bb1d193013460db1f8cc6bff109

Notes

AuthorNote
leosilva
backporting this to xenial is too intrusive, hence we will not be fixing
this in xenial/esm neither in trusty/esm.

References

Bugs