CVE-2020-15704

Published: 04 August 2020

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
ppp
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla)
Released (2.4.7-2+4.1ubuntu6)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.4.7-2+4.1ubuntu5.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.4.7-2+2ubuntu1.3)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.4.7-1+2ubuntu1.16.04.3)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.4.5-5.1ubuntu2.3+esm2)
Ubuntu 12.04 ESM (Precise Pangolin)
Released (2.4.5-5ubuntu1.4)