CVE-2020-14403

Published: 17 June 2020

An issue was discovered in LibVNCServer before 0.9.13. libvncserver/hextile.c allows out-of-bounds access via encodings.

Priority

Medium

CVSS 3 base score: 5.4

Status

Package Release Status
libvncserver
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(0.9.13+dfsg-1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (0.9.12+dfsg-9ubuntu0.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.9.11+dfsg-1ubuntu1.3)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (0.9.10+dfsg-3ubuntu0.16.04.5)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/LibVNC/libvncserver/commit/74e8a70f2c9a5248d6718ce443e07c7ed314dfff
veyon
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 LTS (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

vino
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla)
Released (3.22.0-6ubuntu2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (3.22.0-5ubuntu2.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (3.22.0-3ubuntu1.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (3.8.1-0ubuntu9.3)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

x11vnc
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.10 (Groovy Gorilla) Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 LTS (Xenial Xerus) Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Needs triage