CVE-2020-14343

Published: 09 February 2021

A vulnerability was discovered in the PyYAML library in versions before 5.4, where it is susceptible to arbitrary code execution when it processes untrusted YAML files through the full_load method or with the FullLoader loader. Applications that use the library to process untrusted input may be vulnerable to this flaw. This flaw allows an attacker to execute arbitrary code on the system by abusing the python/object/new constructor. This flaw is due to an incomplete fix for CVE-2020-1747.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
pyyaml
Launchpad, Ubuntu, Debian
Upstream
Released (5.4.1)
Ubuntu 21.04 (Hirsute Hippo)
Released (5.3.1-3ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (5.3.1-1ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(code not present)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)
Patches:
Upstream: https://github.com/yaml/pyyaml/commit/7adc0db3f613a82669f2b168edd98379b83adb3c