CVE-2020-12401

Published: 05 August 2020

During ECDSA signature generation, padding applied in the nonce designed to ensure constant-time scalar multiplication was removed, resulting in variable-time execution dependent on secret data. This vulnerability affects Firefox < 80 and Firefox for Android < 80.

Priority

Medium

CVSS 3 base score: 4.7

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
Upstream
Released (80)
Ubuntu 20.10 (Groovy Gorilla)
Released (80.0.1+build1-0ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (80.0+build2-0ubuntu0.20.04.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (80.0+build2-0ubuntu0.18.04.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (80.0+build2-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

nss
Launchpad, Ubuntu, Debian
Upstream
Released (2:3.55-1)
Ubuntu 20.10 (Groovy Gorilla)
Released (2:3.55-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2:3.49.1-1ubuntu1.4)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2:3.35-2ubuntu2.11)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2:3.28.4-0ubuntu0.16.04.13)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2:3.28.4-0ubuntu0.14.04.5+esm7)
Patches:
Upstream: https://hg.mozilla.org/projects/nss/rev/aeb2e583ee957a699d949009c7ba37af76515c20