CVE-2020-12135

Published: 24 April 2020

bson before 0.8 incorrectly uses int rather than size_t for many variables, parameters, and return values. In particular, the bson_ensure_space() parameter bytesNeeded could have an integer overflow via properly constructed bson input.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
duo-unix
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Needs triage

Ubuntu 20.10 (Groovy Gorilla) Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

whoopsie
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo)
Released (0.2.71)
Ubuntu 20.10 (Groovy Gorilla)
Released (0.2.71)
Ubuntu 20.04 LTS (Focal Fossa)
Released (0.2.69ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.2.62ubuntu0.5)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.2.52.5ubuntu0.5)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist