Your submission was sent successfully! Close

CVE-2020-11039

Published: 29 May 2020

In FreeRDP less than or equal to 2.0.0, when using a manipulated server with USB redirection enabled (nearly) arbitrary memory can be read and written due to integer overflows in length checks. This has been patched in 2.1.0.

Priority

Low

CVSS 3 base score: 6.8

Status

Package Release Status
freerdp
Launchpad, Ubuntu, Debian
bionic Needed

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Needed

freerdp2
Launchpad, Ubuntu, Debian
bionic
Released (2.1.1+dfsg1-0ubuntu0.18.04.1)
eoan
Released (2.1.1+dfsg1-0ubuntu0.19.10.1)
focal
Released (2.1.1+dfsg1-0ubuntu0.20.04.1)
groovy Not vulnerable
(2.1.1+dfsg1-1)
hirsute Not vulnerable
(2.1.1+dfsg1-1)
impish Not vulnerable
(2.1.1+dfsg1-1)
jammy Not vulnerable
(2.1.1+dfsg1-1)
precise Does not exist

trusty Does not exist

upstream
Released (2.1.1+dfsg1-1)
xenial Does not exist