CVE-2020-10802

Published: 22 March 2020

In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability has been discovered where certain parameters are not properly escaped when generating certain queries for search actions in libraries/classes/Controllers/Table/TableSearchController.php. An attacker can generate a crafted database or table name. The attack can be performed if a user attempts certain search operations on the malicious database or table.

From the Ubuntu security team

It was discovered that phpMyAdmin failed to sanitize certain input. An attacker could use this vulnerability to execute an SQL injection attack via a specially crafted database or table name.

Priority

Medium

CVSS 3 base score: 8.0

Status

Package Release Status
phpmyadmin
Launchpad, Ubuntu, Debian
Upstream
Released (4:4.2.12-2+deb8u9, 4:4.6.6-4+deb9u1, 4:4.9.5+dfsg1-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4:4.9.5+dfsg1-1ubuntu1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(4:4.9.5+dfsg1-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4:4.9.5+dfsg1-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (4:4.6.6-5ubuntu0.5)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Needed