CVE-2019-9495

Published: 10 April 2019

The implementations of EAP-PWD in hostapd and wpa_supplicant are vulnerable to side-channel attacks as a result of cache access patterns. All versions of hostapd and wpa_supplicant with EAP-PWD support are vulnerable. The ability to install and execute applications is necessary for a successful attack. Memory access patterns are visible in a shared cache. Weak passwords may be cracked. Versions of hostapd/wpa_supplicant 2.7 and newer, are not vulnerable to the timing attack described in CVE-2019-9494. Both hostapd with EAP-pwd support and wpa_supplicant with EAP-pwd support prior to and including version 2.7 are affected.

Priority

Medium

CVSS 3 base score: 3.7

Status

Package Release Status
wpa
Launchpad, Ubuntu, Debian
Upstream
Released (2.8)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2:2.6-15ubuntu2.2)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.4-0ubuntu6.4)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.1-0ubuntu1.7)
wpasupplicant
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist