CVE-2019-3835

Published: 21 March 2019

It was found that the superexec operator was available in the internal dictionary in ghostscript before 9.27. A specially crafted PostScript file could use this flaw in order to, for example, have access to the file system outside of the constrains imposed by -dSAFER.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
ghostscript
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver)
Released (9.26~dfsg+0-0ubuntu0.18.04.8)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (9.26~dfsg+0-0ubuntu0.16.04.8)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [9.26~dfsg+0-0ubuntu0.14.04.8])
Patches:
Upstream: http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=205591753126802da850ada6511a0ff8411aa287
Upstream: http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=d683d1e6450d74619e6277efeebfc222d9a5cb91