CVE-2019-14834

Published: 07 January 2020

A vulnerability was found in dnsmasq before version 2.81, where the memory leak allows remote attackers to cause a denial of service (memory consumption) via vectors involving DHCP response creation.

Priority

Low

CVSS 3 base score: 3.7

Status

Package Release Status
dnsmasq
Launchpad, Ubuntu, Debian
Upstream
Released (2.81)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(2.81-4)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(2.81-4)
Ubuntu 20.04 LTS (Focal Fossa)
Released (2.80-1.1ubuntu1.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.79-1ubuntu0.2)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (2.75-1ubuntu0.16.04.7)
Ubuntu 14.04 ESM (Trusty Tahr) Needs triage

Patches:
Upstream: http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=69bc94779c2f035a9fffdb5327a54c3aeca73ed5