Your submission was sent successfully! Close

CVE-2019-11745

Published: 25 November 2019

When encrypting with a block cipher, if a call to NSC_EncryptUpdate was made with data smaller than the block size, a small out of bounds write could occur. This could have caused heap corruption and a potentially exploitable crash. This vulnerability affects Thunderbird < 68.3, Firefox ESR < 68.3, and Firefox < 71.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
bionic
Released (71.0+build5-0ubuntu0.18.04.1)
disco
Released (71.0+build5-0ubuntu0.19.04.1)
eoan
Released (71.0+build5-0ubuntu0.19.10.1)
precise Does not exist

trusty Does not exist

upstream
Released (71.0)
xenial
Released (71.0+build5-0ubuntu0.16.04.1)
nss
Launchpad, Ubuntu, Debian
bionic
Released (2:3.35-2ubuntu2.5)
disco
Released (2:3.42-1ubuntu2.3)
eoan
Released (2:3.45-1ubuntu2.1)
precise
Released (2:3.28.4-0ubuntu0.12.04.5)
trusty
Released (2:3.28.4-0ubuntu0.14.04.5+esm2)
upstream
Released (3.44.3,3.47.1)
xenial
Released (2:3.28.4-0ubuntu0.16.04.8)
Patches:
upstream: https://hg.mozilla.org/projects/nss/rev/1e22a0c93afe9f46545560c86caedef9dab6cfda (master)
upstream: https://hg.mozilla.org/projects/nss/rev/60bca7c6dc6dc44579b9b3e0fb62ca3b82d92eec (3.44)
upstream: https://hg.mozilla.org/projects/nss/rev/4c20de402b3901df0cde590a46be2ba49adc028e (3.47)
thunderbird
Launchpad, Ubuntu, Debian
bionic
Released (1:68.4.1+build1-0ubuntu0.18.04.1)
disco Ignored
(reached end-of-life)
eoan
Released (1:68.4.1+build1-0ubuntu0.19.10.1)
precise Does not exist

trusty Does not exist

upstream
Released (68.3)
xenial
Released (1:68.7.0+build1-0ubuntu0.16.04.2)