CVE-2018-20189

Published: 17 December 2018

In GraphicsMagick 1.3.31, the ReadDIBImage function of coders/dib.c has a vulnerability allowing a crash and denial of service via a dib file that is crafted to appear with direct pixel values and also colormapping (which is not available beyond 8-bits/sample), and therefore lacks indexes initialization.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
graphicsmagick
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.4~hg15873-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.4~hg15873-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.4~hg15873-1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.3.28-2ubuntu0.1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Needed