Your submission was sent successfully! Close

CVE-2018-19211

Published: 12 November 2018

In ncurses 6.1, there is a NULL pointer dereference at function _nc_parse_entry in parse_entry.c that will lead to a denial of service attack. The product proceeds to the dereference code path even after a "dubious character `*' in name or alias field" detection.

Priority

Low

CVSS 3 base score: 5.5

Status

Package Release Status
ncurses
Launchpad, Ubuntu, Debian
bionic
Released (6.1-1ubuntu1.18.04)
cosmic Not vulnerable
(6.1+20180210-4ubuntu1)
disco Not vulnerable
(6.1+20180210-4ubuntu1)
eoan Not vulnerable
(6.1+20180210-4ubuntu1)
focal Not vulnerable
(6.2-0ubuntu2)
groovy Not vulnerable
(6.2-0ubuntu2)
hirsute Not vulnerable
(6.2-0ubuntu2)
impish Not vulnerable
(6.2+20201114-2build1)
jammy Not vulnerable
(6.3-2)
precise Ignored
(end of ESM support, was needed)
trusty
Released (5.9+20140118-1ubuntu1+esm2)
upstream
Released (6.1-20180414, 6.1+20180210-3)
xenial
Released (6.0+20160213-1ubuntu1+esm2)
Patches:
upstream: https://github.com/mirror/ncurses/commit/b93d96b78ac5250135975df892cee793dc3c0797