CVE-2018-17206

Published: 19 September 2018

An issue was discovered in Open vSwitch (OvS) 2.7.x through 2.7.6. The decode_bundle function inside lib/ofp-actions.c is affected by a buffer over-read issue during BUNDLE action decoding.

Priority

Medium

CVSS 3 base score: 4.9

Status

Package Release Status
openvswitch
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.9.2-0ubuntu0.18.04.3)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.5.5-0ubuntu0.16.04.2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [code not present])
Patches:
Upstream: https://github.com/openvswitch/ovs/commit/5026a263d7846077eee540de42192d27da513226 (master)
Upstream: https://github.com/openvswitch/ovs/commit/20626d38c1a1d4cebb5a6911ea3cb6a7f4f993f8 (branch-2.8)
Upstream: https://github.com/openvswitch/ovs/commit/9237a63c47bd314b807cda0bd2216264e82edbe8 (branch-2.7)
Upstream: https://github.com/openvswitch/ovs/commit/e1b5444c2f2ed4bda2c75597468f067ae104319d (2.5)
Upstream: https://github.com/openvswitch/ovs/commit/d69fee374bc94fa4ff9836aef7b2855a565dd83f (2.9)