CVE-2018-15473

Published: 17 August 2018

OpenSSH through 7.7 is prone to a user enumeration vulnerability due to not delaying bailout for an invalid authenticating user until after the packet containing the request has been fully parsed, related to auth2-gss.c, auth2-hostbased.c, and auth2-pubkey.c.

Priority

Low

CVSS 3 base score: 5.3

Status

Package Release Status
openssh
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable

Ubuntu 18.04 LTS (Bionic Beaver)
Released (1:7.6p1-4ubuntu0.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1:7.2p2-4ubuntu2.6)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:6.6p1-2ubuntu2.11)
openssh-ssh1
Launchpad, Ubuntu, Debian
Upstream Ignored
(frozen on openssh 7.5p)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable

Ubuntu 20.10 (Groovy Gorilla) Not vulnerable

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable

Ubuntu 16.04 LTS (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Notes

AuthorNote
seth-arnold
openssh-ssh1 is provided for compatibility with old devices that
cannot be upgraded to modern protocols. Thus we may not provide security
support for this package if doing so would prevent access to equipment.
openssh-ssh1 is a *client-only* package, no server-side facility, so
there is no path to leak data
mdeslaur
watch for regressions, see debian ELA-37-3
leosilva
for openss, cosmic is not affected, and so disco too.

References

Bugs