CVE-2018-1303

Published: 26 March 2018

A specially crafted HTTP request header could have crashed the Apache HTTP Server prior to version 2.4.30 due to an out of bound read while preparing data to be cached in shared memory. It could be used as a Denial of Service attack against users of mod_cache_socache. The vulnerability is considered as low risk since mod_cache_socache is not widely used, mod_cache_disk is not concerned by this vulnerability.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
apache2
Launchpad, Ubuntu, Debian
Upstream
Released (2.4.30)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (2.4.29-1ubuntu4.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.4.18-2ubuntu3.8)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.4.7-1ubuntu4.20)
Patches:
Upstream: https://svn.apache.org/viewvc?view=revision&revision=1824343
Upstream: https://svn.apache.org/viewvc?view=revision&revision=1824475 (2.4)