CVE-2018-1285

Published: 11 May 2020

Apache log4net versions before 2.0.10 do not disable XML external entities when parsing log4net configuration files. This allows for XXE-based attacks in applications that accept attacker-controlled log4net configuration files.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
log4net
Launchpad, Ubuntu, Debian
Upstream
Released (1.2.10+dfsg-6+deb8u1)
Ubuntu 21.04 (Hirsute Hippo) Needed

Ubuntu 20.10 (Groovy Gorilla)
Released (1.2.10+dfsg-7ubuntu0.20.10.1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (1.2.10+dfsg-7ubuntu0.20.04.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.2.10+dfsg-7ubuntu0.18.04.1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1.2.10+dfsg-7ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist