Your submission was sent successfully! Close

CVE-2018-1086

Published: 12 April 2018

pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
pcs
Launchpad, Ubuntu, Debian
Upstream
Released (0.9.164-1)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(0.10.1-2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(0.10.1-2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.10.1-2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.9.164-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist