Your submission was sent successfully! Close

CVE-2018-10657

Published: 02 May 2018

Matrix Synapse before 0.28.1 is prone to a denial of service flaw where malicious events injected with depth = 2^63 - 1 render rooms unusable, related to federation/federation_base.py and handlers/message.py, as exploited in the wild in April 2018.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
matrix-synapse
Launchpad, Ubuntu, Debian
Upstream
Released (0.28.1+dfsg-1)
Ubuntu 21.10 (Impish Indri)
Released (0.28.1+dfsg-1)
Ubuntu 21.04 (Hirsute Hippo)
Released (0.28.1+dfsg-1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (0.28.1+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://github.com/matrix-org/synapse/commit/33f469ba19586bbafa0cf2c7d7c35463bdab87eb