CVE-2018-1000168

Published: 12 April 2018

nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
nghttp2
Launchpad, Ubuntu, Debian
Upstream
Released (1.31.1)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.30.0-1ubuntu1)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(1.7.1-1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist