CVE-2017-7823

Published: 02 October 2017

The content security policy (CSP) "sandbox" directive did not create a unique origin for the document, causing it to behave as if the "allow-same-origin" keyword were always specified. This could allow a Cross-Site Scripting (XSS) attack to be launched from unsafe content. This vulnerability affects Firefox < 56, Firefox ESR < 52.4, and Thunderbird < 52.4.

Priority

Medium

CVSS 3 base score: 5.4

Status

Package Release Status
firefox
Launchpad, Ubuntu, Debian
Upstream
Released (56.0)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (56.0+build6-0ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (56.0+build6-0ubuntu0.16.04.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [56.0+build6-0ubuntu0.14.04.1])
thunderbird
Launchpad, Ubuntu, Debian
Upstream
Released (52.4.0)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (1:52.4.0+build1-0ubuntu2)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:52.4.0+build1-0ubuntu0.16.04.2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1:52.4.0+build1-0ubuntu0.14.04.2])