CVE-2017-7544

Published: 21 September 2017

libexif through 0.6.21 is vulnerable to out-of-bounds heap read vulnerability in exif_data_save_data_entry function in libexif/exif-data.c caused by improper length computation of the allocated data of an ExifMnote entry which can cause denial-of-service or possibly information disclosure.

Priority

Low

CVSS 3 base score: 9.1

Status

Package Release Status
libexif
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(0.6.21-5.1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.6.21-4)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (0.6.21-2ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (0.6.21-1ubuntu1+esm1)
Ubuntu 12.04 ESM (Precise Pangolin)
Released (0.6.20-2ubuntu0.2)
Patches:
Upstream: http://libexif.cvs.sourceforge.net/viewvc/libexif/libexif/libexif/exif-data.c?r1=1.131&r2=1.132